1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Band of Others is populated with passionate Gamers maintaining friendships from time of registration up to 15+ years. Members comprise of good people like you with widely varying levels of Gaming experience.

    We actively support a wide range of Gaming Genres such as First Person Shooters, Role Playing Games, Simulations and even Strategy Games.

    We maintain our own 500+ slot Teamspeak 3 Server with plenty of room for you and your friends to chat.

    For those of you looking for information on our iRacing programs such as Blancpain GT3 League and Practice Pals, please see here.

    Join us today, you'll be glad you did!
    Dismiss Notice

iRacing Session Launch Error - Failed CreateProcessAsUser [740]

Discussion in 'iRacing Forum' started by John Navara, Jul 24, 2017.

  1. John Navara

    John Navara Casual

    Joined:
    Feb 24, 2017
    Messages:
    87
    I need some help here:

    I updated iRacing last week and I was asked if I wanted to install the desktop shortcut, which I did. When I went back to the site to race I am getting the following errror:

    The following error occurred while trying to join the session:
    Failed CreateProcessAsUser [740]

    I tried hosted sessions, practice sessions and test sessions. I also rebooted several times.

    It works perfectly fine running from the shortcut which takes me to the new interface. Problem with that is that I cannot access league races. :cry:

    It looks like it might be a permissions problem when searching on Google. Using Windows 10 and tried starting the program from Google Chrome and Microsoft Edge.

    The response from iRacing support is to uninstall and reinstall. If that doesn't work reinstall my OS. NOT GOING TO HAPPEN.

    John
     
  2. Duke

    Duke Staff Member Site Admin

    Joined:
    Dec 18, 2011
    Messages:
    7,628
    I never installed the shortcut as I prefer to launch through the web interface as that's what I'm used to.

    First off I'd make a backup of your iRacing folder located in My Documents as that'll have replays, settings and others important stuff.

    Then I'd uninstall iRacing through Windows uninstaller. Check to see it got rid of the iRacing folders most likely located in steamapps.

    Reboot and run a clean install of iRacing and see if that works.

    I can't see you needing to reinstall your OS unless it's been giving you trouble in other areas.
     
    John Navara likes this.
  3. John Navara

    John Navara Casual

    Joined:
    Feb 24, 2017
    Messages:
    87
    Thanks for the reply Ken.

    I don't have iRacing installed thru Steam. Straight install from the file I downloaded on the iRacing site.

    I did the uninstall/reinstall once already but I didn't go back and delete iRacing directories before reinstalling. It's frustrating that I cannot run any league sessions. Testing, races and hosted sessons work fine.

    I also cannot believe reinstalling the OS was an option that iRacing threw out there. This is the only program that I am having problems with.

    John
     
  4. John Navara

    John Navara Casual

    Joined:
    Feb 24, 2017
    Messages:
    87
    @Duke Thanks for the suggestion. I uninstalled the program, copied the iRacing directories from Program Files\ and My Documents, deleted them both and reinstalled. It seems to be working now from the website. I'll have to go back through and figure out which ini files I need to move from my backups. I can join league races now. WooHoo.

    John
     
    Duke likes this.
  5. Duke

    Duke Staff Member Site Admin

    Joined:
    Dec 18, 2011
    Messages:
    7,628
    Awesome you got it sorted out John :)
     
    John Navara likes this.
  6. Noodleguitar

    Noodleguitar Moderator

    Joined:
    Mar 19, 2014
    Messages:
    1,264
    I would try moving your backup iRacing folder back to My Documents\iRacing. It should only contain your keybindings, game settings, video settings, controller settings, camera settings and all of the additional content (setups, paints, lap data etc.). I'm not too sure about "core.ini", I would let iRacing re-generate that to be sure.

    Most likely the permission error was caused during an update rather than something in the local files but don't take my word for it.
     
    John Navara likes this.
  7. Duke

    Duke Staff Member Site Admin

    Joined:
    Dec 18, 2011
    Messages:
    7,628
    I thought the same @Noodleguitar but was erring on the side of caution.

    I've personally not installed the shortcut and since it's an .exe I have no idea what it's looking for if you choose not to launch through it? It was just safer to move everything and perform a clean install.

    Then you can move the backup stuff back in individually and when you start experiencing issues you usually locate the source of the issue.
     
    John Navara likes this.

Share This Page